cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <>
Subject Re: Inconsistent property name?
Date Tue, 12 Jun 2012 20:12:10 GMT
Ah good catch. You are absolutely right.

One caveat though. Since we are in Beta now, we should follow our own self-imposed rules and
avoid changing the API (property renaming being such a change IMO). 

I guess we can fix the String value for "ROP_SERVICE_TIMEOUT_PROPERTY" constant, but also
keep the old value around as a deprecated "synonym". I.e. if a user defines a value for "cayenne.rop.service.timeout",
we should load that into "cayenne.rop.service_timeout" internally. I know it is a pain...

Should probably Jira that too so that it is recorded in RELEASE-NOTES.


On Jun 12, 2012, at 10:44 PM, John Huss wrote:

> I'm updated my app to the most recent 3.1 and I think I found one property
> name is wrong in org.apache.cayenne.configuration.Constants:
> cayenne.rop.service.timeout
> Seems to be inconsistent with the other properties, which all have an
> underscore after "service", for example:
> cayenne.rop.service_url
> cayenne.rop.service_username
> cayenne.rop.service_password
> If that sounds right I will change it to use an underscore.
> John

View raw message