cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Gentry <mgen...@masslight.net>
Subject Re: docbook build failure
Date Mon, 28 May 2012 23:13:00 GMT
So you can't build now without Maven 3?

~/Projects/Cayenne31$ mvn clean install
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Unable to build project
'/home/mrg/Projects/Cayenne31/docs/docbook/pom.xml; it requires Maven
version 3
[INFO] ------------------------------------------------------------------------

mrg


On Wed, May 23, 2012 at 10:47 AM, Aristedes Maniatis <ari@maniatis.org> wrote:
> That was my hunch, but I forced the pom to a minimum of maven 3 and it
> didn't help.
>
> Ari
>
>
>
>
> On 23/05/12 11:03pm, Andrus Adamchik wrote:
>>
>> I noticed you've asked about Maven version in INFRA-4023 comment. I think
>> this is the most likely cause.
>>
>> Andrus
>>
>>
>> On May 23, 2012, at 3:52 AM, Aristedes Maniatis wrote:
>>
>>> Does anyone have ideas about this one:
>>>
>>>
>>> http://ci.apache.org/builders/cayenne-nightly/builds/224/steps/compile_1/logs/stdio
>>>
>>> It works for me locally, so I'm out of ideas. Why does
>>> ${project.parent.basedir} come out as null? Isn't that a built-in maven
>>> property? I guess I could replace it with "../" but that seems less robust
>>> somehow.
>>>
>>>
>>> Ari
>>>
>>>
>>>
>>> --
>>> -------------------------->
>>> Aristedes Maniatis
>>> GPG fingerprint CBFB 84B4 738D 4E87 5E5C  5EFA EF6A 7D2E 3E49 102A
>>>
>>>
>>
>
> --
> -------------------------->
> Aristedes Maniatis
> GPG fingerprint CBFB 84B4 738D 4E87 5E5C  5EFA EF6A 7D2E 3E49 102A
>
>

Mime
View raw message