cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: DataDomain.getNode(String nodeName)
Date Fri, 23 Mar 2012 14:29:21 GMT
+1 

On Mar 23, 2012, at 5:27 PM, John Huss wrote:

> Shouldn't "DataDomain.getNode(String nodeName)" be called getDataNode
> instead?  I see there is a deprecated "getMap(String mapName)" method.  It
> seems like this should also be deprecated and replace with getDataNode.
> It's easy to miss othewise, since there is a getDataNodes() method get all
> nodes - it's inconsistent.
> 
> I can submit a patch if you like.
> 
> John


Mime
View raw message