cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Huss <johnth...@gmail.com>
Subject DataDomain.getNode(String nodeName)
Date Fri, 23 Mar 2012 14:27:18 GMT
Shouldn't "DataDomain.getNode(String nodeName)" be called getDataNode
instead?  I see there is a deprecated "getMap(String mapName)" method.  It
seems like this should also be deprecated and replace with getDataNode.
 It's easy to miss othewise, since there is a getDataNodes() method get all
nodes - it's inconsistent.

I can submit a patch if you like.

John

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message