cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Huss <johnth...@gmail.com>
Subject Re: Building in eclipse with m2e
Date Tue, 03 Jan 2012 15:23:57 GMT
I still haven't gotten this to work, but I found out you can get it to
ignore the error by doing quick fix and telling it to ignore it.  That's
better than editing the pom to remove the problem parts.

On Thu, Dec 29, 2011 at 11:21 AM, John Huss <johnthuss@gmail.com> wrote:

> Yes, I've run the build from the command line first and I still have the
> same errors.
>
>
> On Wed, Dec 28, 2011 at 7:01 PM, Michael Gentry <mgentry@masslight.net>wrote:
>
>> Hi John,
>>
>> Did you build it from the command-line first using:
>>
>> mvn clean install
>>
>> I forget the reason, but I think you have to build from the
>> command-line before m2e works in Eclipse.
>>
>> mrg
>>
>>
>> On Wed, Dec 28, 2011 at 6:30 PM, John Huss <johnthuss@gmail.com> wrote:
>> > I'm not able to build cayenne in eclipse with m2e due to the following
>> > errors.  Previously I have just removed the offending lines as a
>> > work-around, but I'd like to get it working correctly.  I'm not a maven
>> > user, so any help would be appreciated.
>> >
>> > Plugin execution not covered by lifecycle configuration:
>> >
>> org.apache.cayenne.build-tools:*maven-cayenne-build-plugin*:3.1M4-SNAPSHOT:date
>> > (execution: *date*, phase: initialize)
>> > pom.xml /cayenne-jdk1.5-unpublished line 234
>> >
>> > Plugin execution not covered by lifecycle configuration:
>> > org.apache.maven.plugins:*maven-antrun-plugin*:1.3:run (execution:
>> default,
>> > phase: process-sources)
>> > pom.xml /cayenne-jdk1.5-unpublished line 196
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message