cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Durchholz, Joachim" <>
Subject RE: [jira] [Created] (CAY-1639) cayenne-lifecycle: don't call String representation of ObjectId a UUID
Date Mon, 07 Nov 2011 11:17:30 GMT
> No separate class. This is a String. So this is more about the "concept name" used in
various methods ("getUuid") and helper classes "UuidCoder".

In that case, my proposal is indeed this one:

> I'd [...] refer to it as "ObjectId in String form" (or, if the context makes it clear,
just as "Object Id").

Possibly as "serialized ObjectId" if that String form is intended for serialization.

I wouldn't create new terminology just for naming different representations of the same semantics.

Just my 5 cents :-)


View raw message