cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcin Skladaniec <mar...@ish.com.au>
Subject Re: maven plugin dependencies
Date Thu, 07 Apr 2011 07:35:19 GMT
Hi

I'm talking about maven-cayenne-plugin based on the 3.1M2 branch, link: http://mvnrepository.com/artifact/org.apache.cayenne.plugins/maven-cayenne-plugin/3.1M2

you can see it is dependent on cayenne-jdk1.5-unpublished and cayenne-project-unpublished.
none of those projects exist in maven central.
the two other dependencies (cayenne-server and cayenne-tools) are there.

Is that possible that you have local repository with those dependencies, therefore you are
not seeing this problems?

Marcin








On 7/04/11 5:23 PM, Andrus Adamchik wrote:
> Are we talking about the Modeler plugin (maven-cayenne-modeler-plugin) or cgen plugin
(maven-cayenne-plugin)? Myself and my team are using cgen plugin in 3.1M2 with no problems.
Of course there's an easy workaround for a broken Modeler plugin - use the Modeler from download
:-)
>
> In either case please open a Jira with Maven errors.
>
> Andrus
>
> On Apr 7, 2011, at 10:16 AM, Marcin Skladaniec wrote:
>
>> Hello Andrus!
>>
>> On 7/04/11 4:31 PM, Andrus Adamchik wrote:
>>> On Apr 7, 2011, at 5:04 AM, Aristedes Maniatis wrote:
>>>
>>>> Looks like we have a problem with the maven plugin.
>>>>
>>>> http://mvnrepository.com/artifact/org.apache.cayenne.plugins/maven-cayenne-modeler-plugin/3.1M2
>>>>
>>>> You can see that there are two issues:
>>>>
>>>> 1. It depends on org.apache.cayenne.unpublished
>>> the scope for that is "provided", so shouldn't be a problem for end users.
>> We are referencing the cayenne maven plugin (cgen) as in http://cayenne.apache.org/doc30/maven2-plugins.html:
>>
>> <build>
>>   <plugins>
>>     <plugin>
>>        <groupId>org.apache.cayenne.plugins</groupId>
>>        <artifactId>maven-cayenne-plugin</artifactId>
>>        <version>3.1M2</version>
>>     </plugin>
>>   </plugins>
>>
>> </build>
>>
>> During build  maven tries to fetch the *.unpublished jars/poms from repo, and fails.
>>>> 2. some of the versions are set to ${version}
>>> Not sure this is a problem (wonder how smart Maven is when resolving these vars)...
>>>
>>> Still we had some user complaints about this plugin. No specific causes where
mentioned IIRC. Not sure what's the status of those (do we have a Jira?) and whether anyone
actually *tried* using it with a clean local repo?
>> Yes, I did. Deleted whole local m2 repo. No difference.
>> Also tried to create the targets from the 3.1M2 tags to add them to our 3rd party
repo, but could not get past the tests for some reason. I know I could have tried to bypass
the tests with -Dmaven.test.skip=true, but then it will be a workaround on top of other workaround,
so I stopped.
>> As for now the 3.1M2 is unusable for us, and presumably other developers relying
on the plugin, shall I open a jira?
>>
>> Thanks
>> Marcin
>>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message