cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aristedes Maniatis <...@maniatis.org>
Subject Re: Java 6 for 3.1?
Date Fri, 28 Jan 2011 22:46:03 GMT
On 29/01/11 12:36 AM, Andrus Adamchik wrote:
> Since Java 5 has been EOL'd for some time, and Java 7 seems to be close to GA, (and there's
no more Java 5 on OS X, so I've no idea whether Cayenne is really java 5 compatible :-)),
how about we make Java 6 a minimal JVM requirement for Cayenne 3.1? Keeping things tight and
all that.

-1 for personal reasons... I use Cayenne in a product which is deployed to 1.5 and cannot
be upgraded since it runs on PPC Macs. I was really hoping to upgrade to 3.1 quite soon in
that product.

But also, we have no idea how many people are using Cayenne in enterprise situations where
they don't get to control the JVM. Last time we moved from 1.4 to 1.5 there was a good reason:
generics. This time around, there is nothing really to be gained and we immediately remove
any PPC Macs from the userbase.

If anyone is using Cayenne, not for a big web application server in a data centre, but out
in the field on a 10 year old desktop or (who knows) porting it to Android (Dalvik is a 'copy'
of Java 5) for some new tablet application, they may well be targeting Java 5. Personally
I still have a couple of PPC machines in the office and they are only 4 years old. Many of
my customers have refresh cycles much longer than 4 years, especially in the education industry.

Oh, there is no problem with Cayenne in Java 5: https://hudson.apache.org/hudson/job/Cayenne-trunk/

Cheers

Ari


-- 
-------------------------->
Aristedes Maniatis
GPG fingerprint CBFB 84B4 738D 4E87 5E5C  5EFA EF6A 7D2E 3E49 102A

Mime
View raw message