cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <and...@objectstyle.org>
Subject Re: Build failed in Hudson: Cayenne-trunk » h2,JDK 1.5 (latest),Ubuntu #372
Date Mon, 04 Oct 2010 20:04:51 GMT
Just reproduced the errors locally running like this:

  mvn clean install -DcayenneTestConnection=h2

Could you doublecheck the property name activating the "h2" profile? It is different between
3.0 and 3.1 branches (above is a 3.1 version per http://cayenne.apache.org/running-unit-tests.html
). The new syntax is due to some stupid Hudson limitations on dots in the property names.

Andrus

On Oct 4, 2010, at 10:55 PM, Andrus Adamchik wrote:

> yeah, I'd think so:
> 
> <dependency>
> 	<groupId>com.h2database</groupId>
> 	<artifactId>h2</artifactId>
> 	<version>1.0.64</version>
> 	<scope>test</scope>
> </dependency>
> 
>> I haven't seen any more Hudson failures since then.
> 
> All my today's commits resulted in the same failures. Build #373.
> 
> Andrus
> 
> On Oct 4, 2010, at 10:38 PM, Michael Gentry wrote:
> 
>> Hi Andrus,
>> 
>> I saw that error e-mail, but when I built and ran tests I didn't get
>> the errors.  Wouldn't the version of H2 to use when running tests be
>> specified in the pom.xml and in theory should be the same?  Is this
>> still happening?  I haven't seen any more Hudson failures since then.
>> 
>> Thanks,
>> 
>> mrg
>> 
>> 
>> On Mon, Oct 4, 2010 at 3:15 PM, Andrus Adamchik <andrus@objectstyle.org> wrote:
>>> Hi Mike (mrg)!
>>> 
>>> Wonder why we are getting a bunch of Hudson H2 errors? Is this a different H2
version compared to what you've tested against?
>>> 
>>> Cheers,
>>> Andrus
>>> 
>>> 
>>> On Sep 28, 2010, at 4:19 PM, Apache Hudson Server wrote:
>>> 
>>> [spew deleted]
>> 
> 
> 


Mime
View raw message