cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Gentry <>
Subject Re: Accessing object metadata and other utilities
Date Tue, 24 Nov 2009 14:34:21 GMT
I tend to not like abbreviations for the most part (a little peeve of
mine -- I fall into the "software is meant to be read, not written"
camp), so I'd vote for something more like "Cayenne" in the current
org.apache.cayenne.util package.  Simple, direct, and to the point.


On Tue, Nov 24, 2009 at 6:53 AM, Andrus Adamchik <> wrote:
> [As suggested in the parent thread, forking a new thread]
> On Nov 24, 2009, at 1:41 PM, Robert Zeigler wrote:
>> I'll second that. I ran into a very similar use case yesterday in a
>> hibernate project... I was wanting to get at hibernate's version of
>> ClassDescription, and it took me forever to track down the right way to do
>> it; once I knew how, it was simple enough, and just a few lines of code, but
>> I fear the above would cause a new Cayenne user the same level of
>> frustration I experienced yesterday with Hibernate. ;)
> I wouldn't mind if we add methods for ClassDescriptor lookups to the
> DataObjectUtils. BTW PersistentObject defines 'getObjEntity' method. I'd say
> we replace that with 'getClassDescriptor' and move it to a utility class.
> While we are at it, maybe rename DataObjectUtils to something more
> appropriate and shorter. CayenneUtil? Cayenne? ("Util" is already taken, and
> I'd rather it identify the origin of the framework).
> I sort of like calling it just "Cayenne" (for the same reasons of user
> simplicity), but then it implies this is a central class in the framework,
> and has more than just lookup-by-pk or give-me-metadata methods.
> Andrus

View raw message