cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Menard <nirvd...@gmail.com>
Subject Re: [VOTE] Apache Cayenne release 3.0B1
Date Thu, 29 Oct 2009 13:44:08 GMT
My vote is -0.

It seems others are able to build it, but I can't.  I just ran into
another issue where the jjtree generation seems to be duplicating the
package name.  So, I end up with paths like
"framework/cayenne-jdk1.5-unpublished/target/generated-sources/jjtree/org/apache/cayenne/ejbql/org/apache/cayenne/ejbql/parser/",
which don't match the package name.  IDEA does not like this, maven
doesn't seem to mind.  I recall seeing this before, but I thought it
got fixed.

No doubt the test failure is related to my snow leopard upgrade,
because all tests were passing before then.  I'm not sure how long the
parser thing has been like this.  Older versions of IDEA may have been
more tolerant of the bad package name and I've been tracking the EAPs.

-- 
Kevin



On Thu, Oct 29, 2009 at 9:34 AM, Tore Halset <halset@pvv.ntnu.no> wrote:
> Hello.
>
> I have tested it with our internal application junit test suite on
> PostgreSQL, Derby and MS SQL Server. No problems found.
>
> I have also done some testing of the modeler. As I have used the modeler
> with earlier 3.0 versions, the upgrade-project message was a bit strange.
> "Project needs an upgrade to a newer version. Older Project Version
> Detected: "3.0". Upgrade?" "3.0" is not such an old version.. I have read
> the separate thread regarding this issue.
>
> So, my vote is: +1
>
>  - Tore.
>
> On Oct 25, 2009, at 17:49 , Andrus Adamchik wrote:
>
>> Release artifacts are posted here:
>>
>> http://people.apache.org/~aadamchik/release/3.0B1/
>>
>> Please evaluate and cast your votes.
>>
>> Cheers,
>> Andrus
>>
>
>

Mime
View raw message