cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrey Razumovsky" <razumovsky.and...@gmail.com>
Subject Re: Weird modeler behavior
Date Tue, 02 Sep 2008 13:31:12 GMT
Andrus,

This is indeed a bug. I've uploaded fix to CAY-1060 as this is an issue had
caused the problems

2008/9/2, Andrey Razumovsky <razumovsky.andrey@gmail.com>:
>
> I can see that on Win too. Multiple selection problem is obviously result
> of my patch. Mess with views needs some investigation, let me have a look
>
> 2008/9/2, Andrus Adamchik <andrus@objectstyle.org>:
>>
>> I have a Mac Modeler build from trunk, just did an rm -rf ~/.cayenne, and
>> opened one of my existing projects.
>>
>> * Doing Command F to search for an entity; type entity name pattern
>> * The window pops up with a list of matching things
>> * I select 1 obj entity. Instead of displaying entity editor, the right
>> panel goes blank.
>>
>> Sometimes this happens on selection of a second entity, not first. I also
>> noticed that if I select multiple entities one after another, multiple
>> selections are made on the left hand tree. Console log doesn't show anything
>> abnormal.
>>
>> Sequence of events above completely messes up the modeler. After that
>> selecting objects from the tree results in overlapping views and other
>> craziness. I can post snapshots if needed.
>>
>> Andrus
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message