cayenne-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aristedes Maniatis <...@ish.com.au>
Subject Re: modeler preference load exception
Date Tue, 05 Aug 2008 23:52:59 GMT

On 04/08/2008, at 2:12 AM, Andrey Razumovsky wrote:

> So you've got problems with launching the modeler, not the tests?
> The stack trace marks the Cayenne's version as v.3.0-SNAPSHOT Oct 26  
> 2007.
> Also line 865 in DataDomain (first line in trace) is meaningless in  
> current
> SVN version of DataDomain class (there's "try" keyword), so seems this
> exception belongs to some old modeler - ?.

Yes, well spotted. From the look of this, I've got an old build in  
there, but the strange thing is that I've rebuilt everything using the  
usual maven mojo at the top level and within specific framework folders:

# mvn clean
# mvn install

I even deleted the target folders. Next thing, I'll dump the relevant  
bits of the .m2 directory and see if I can trick maven into installing  
the artifacts which it just spent 5 minutes building rather than  
something it found somewhere on disk from last October. I'll do that  
today - not sure why I've got problems now and never have before.  
Maybe my recent upgrade to maven 2.0.9?

Ari


-------------------------->
ish
http://www.ish.com.au
Level 1, 30 Wilson Street Newtown 2042 Australia
phone +61 2 9550 5001   fax +61 2 9550 4001
GPG fingerprint CBFB 84B4 738D 4E87 5E5C  5EFA EF6A 7D2E 3E49 102A



Mime
View raw message