cayenne-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ntimof...@apache.org
Subject cayenne git commit: Java 8 usage upgrade notes
Date Mon, 21 Aug 2017 11:03:15 GMT
Repository: cayenne
Updated Branches:
  refs/heads/master eb512d58f -> ece8fc2e4


Java 8 usage upgrade notes


Project: http://git-wip-us.apache.org/repos/asf/cayenne/repo
Commit: http://git-wip-us.apache.org/repos/asf/cayenne/commit/ece8fc2e
Tree: http://git-wip-us.apache.org/repos/asf/cayenne/tree/ece8fc2e
Diff: http://git-wip-us.apache.org/repos/asf/cayenne/diff/ece8fc2e

Branch: refs/heads/master
Commit: ece8fc2e4ddad222b1a2eac002087a0392563465
Parents: eb512d5
Author: Nikita Timofeev <stariy95@gmail.com>
Authored: Mon Aug 21 14:02:58 2017 +0300
Committer: Nikita Timofeev <stariy95@gmail.com>
Committed: Mon Aug 21 14:02:58 2017 +0300

----------------------------------------------------------------------
 docs/doc/src/main/resources/UPGRADE.txt | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cayenne/blob/ece8fc2e/docs/doc/src/main/resources/UPGRADE.txt
----------------------------------------------------------------------
diff --git a/docs/doc/src/main/resources/UPGRADE.txt b/docs/doc/src/main/resources/UPGRADE.txt
index 942e473..e2ecdc4 100644
--- a/docs/doc/src/main/resources/UPGRADE.txt
+++ b/docs/doc/src/main/resources/UPGRADE.txt
@@ -7,6 +7,9 @@ IMPORTANT: be sure to read all notes for the intermediate releases between
your
 
 UPGRADING TO 4.1.M1
 
+* Per CAY-2351 Minimum supported Java version is now Java 8. There is no options to use Cayenne
4.1 with earlier
+      versions, you should use 4.0 version if Java 7 is required by your project.
+
 * Per CAY-2345 Velocity replaced with Cayenne own template engine by default in cayenne-server,
       this should be transparent in almost all cases, however if you relied on advanced Velocity
       features in SQLTemplate you can include auto-loaded cayenne-velocity module and keep
using Velocity,
@@ -14,7 +17,7 @@ UPGRADING TO 4.1.M1
 
 * Per CAY-2335 ServerRuntime by default will fail to load projects in case of version mismatch.
       You have two options:
-      - update project via opening it in Cayenne Modeler
+      - update project files via opening them in Cayenne Modeler
       - if you are unable to do so you can use new cayenne-project-compatibility module,
       to enable it simply add it as a dependency in Maven (or any other build system you
use), however
       this module can support only versions created by Cayenne 3.1 or later.


Mime
View raw message