cayenne-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ari Maniatis (JIRA)" <j...@apache.org>
Subject [jira] Closed: (CAY-912) Lookup fields not working on jtable
Date Wed, 06 Jan 2010 09:51:54 GMT

     [ https://issues.apache.org/jira/browse/CAY-912?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ari Maniatis closed CAY-912.
----------------------------

    Resolution: Won't Fix

Data views has gone away.

> Lookup fields not working on jtable
> -----------------------------------
>
>                 Key: CAY-912
>                 URL: https://issues.apache.org/jira/browse/CAY-912
>             Project: Cayenne
>          Issue Type: Bug
>          Components: DataViews
>    Affects Versions: 2.0 branch
>         Environment: JRE 1.5 + Windows Vista :-(
>            Reporter: borgo
>            Assignee: Andrus Adamchik
>
> I have tried to use DataViews with the following example code (http://cayenne.apache.org/doc20/dataviews-in-action.html)
> The DataViews documentation It's not clear about use the lookup when editing a JTable.

> Two problem arise:
> 1) Lookups combobox are always empty
> I have look at createTableCellEditor() methods in CellEditors
> Here the method field.getLookupValues() returns always an empty list.
> The cause is getRootOwner().getLookupCache().getCachedValues(lookupField) that returns
always an empty list.
> I think it's because I haven't setting any data in the cache. 
> But how could I do that ? Does I need to create query in the modeller ? 
> Unluckly, documentation and examples doesn't help to understand how cache and lookup
fields works.
> 2) So I have tried to use a custom method to load the lookup combobox.
> Here is another problem: when I pickup an element, the cell in the table is not updated
and becomes empty.
> there is no way to update the cell choosing elements from the combo.
> I'm very interested in DataViews. My first reason to use Cayenne is the presence of DataViews.
> I'd like to give my contributes to that project but first we need a working base to develop
on.
> Regars
> Andrea

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message