cayenne-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Zeigler (JIRA)" <j...@apache.org>
Subject [jira] Updated: (CAY-1184) Callback methods should default to usable names
Date Tue, 10 Mar 2009 18:13:16 GMT

     [ https://issues.apache.org/cayenne/browse/CAY-1184?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Zeigler updated CAY-1184:
--------------------------------

    Fix Version/s: 3.0M6
         Priority: Minor  (was: Major)
          Summary: Callback methods should default to usable names  (was: Callback methods
should be named user-friendly)

I went with "onXXX" (onPreUpdate, onPostLoad, etc.) rather than preUpdate, postLoad, etc.
to emphasize the callback-nature of the method.

> Callback methods should default to usable names
> -----------------------------------------------
>
>                 Key: CAY-1184
>                 URL: https://issues.apache.org/cayenne/browse/CAY-1184
>             Project: Cayenne
>          Issue Type: Improvement
>          Components: CayenneModeler GUI
>    Affects Versions: 3.0M5
>            Reporter: Andrey Razumovsky
>            Assignee: Robert Zeigler
>            Priority: Minor
>             Fix For: 3.0M6
>
>
> Callback methods should be named better by default (not "untitled"). I assume "preUpdate"
etc. would be much better

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message