cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Ramirez <erick.rami...@datastax.com>
Subject cassandra-cli on 3.x
Date Wed, 12 Feb 2020 01:31:33 GMT
Jai, Thrift was deprecated years ago (maybe 5 or 6?) and COMPACT STORAGE
was dropped since the refactor of the storage engine in C* 3.0 so there
won't be support for any legacy CLI. In fact, you need to migrate off
legacy storage when you upgrade using ALTER TABLE ks.table DROP COMPACT
STORAGE.

You won't be able to upgrade to 3.x versions until your application has
migrated off legacy drivers since they won't be supported. Out of
curiosity, which driver is your application using? I highly doubt it would
still be supported by someone since most development on Thrift clients
ended years ago.

For more info on DROP COMPACT STORAGE, see this KB article I wrote a couple
of years ago -- https://support.datastax.com/hc/en-us/articles/360000943523.
Cheers!

Mime
View raw message