cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dipan Shah <>
Subject Re: Cassandra 3.10 Bootstrap- Error
Date Tue, 24 Oct 2017 13:12:56 GMT
Hi Anumod,

I faced the same issue with 3.11 and I'll suggest you first go through this link to check
if the new node is able to communicate back on forth on the required port with the seed node.


Bootstap fails with "Unable to gossip with any seeds" yet ...<>
DataStax Support; DataStax Enterprise; Install/Upgrade; Bootstap fails with "Unable to gossip
with any seeds" yet new node can connect to seed nodes

This will mostly be the issue but even if that is not solving your problem, check the following

1) Check free disk space on the seed nodes. There should be sufficient free space for data
migration to the new node.

2) Check logs of the seed nodes and see if there are any errors. I found some gossip file
corruption on one of the seed nodes.

3) Finally, restart server\cassandra services on the seed nodes and see if that helps.

Do let me know if this solved your problem.


Dipan Shah

From: Anumod Mullachery <>
Sent: Tuesday, October 24, 2017 2:12 AM
Subject: Cassandra 3.10 Bootstrap- Error


We are using cassandra 3.10 , with Network topology strategy , & 2 DC having only 1 node

We are trying to add New nodes (auto_bootstrap: true) in yaml ,  but getting the below error-

In the Seed nodes list, we have provided both the existing nodes from both DC(total -2 nodes).
& tried with different option, by keeping only 1 node, but no hope.

2017-10-23 20:06:31,739 [MessagingService-Outgoing-/] WARN
- Filtering out [TLS_RSA_WITH_AES_256_CBC_SHA] as it isn't supported by the socket
2017-10-23 20:06:31,739 [MessagingService-Outgoing-/] ERROR
- SSL handshake error for outbound connection to 15454e08[SSL_NULL_WITH_NULL_NULL: Socket[addr=/<>,port=10145,localport=60859]] No appropriate protocol (protocol is disabled or cipher
suites are inappropriate)

2017-10-23 20:06:32,655 [main] ERROR - Exception encountered during
java.lang.RuntimeException: Unable to gossip with any seeds

2017-10-23 20:06:32,666 [StorageServiceShutdownHook] INFO - Paused
hints dispatch
2017-10-23 20:06:32,667 [StorageServiceShutdownHook] WARN - No local
state, state is in silent shutdown, or node hasn't joined, not announcing shutdown
2017-10-23 20:06:32,667 [StorageServiceShutdownHook] INFO - Waiting
for messaging service to quiesce
2017-10-23 20:06:32,667 [ACCEPT-/<>] INFO
- MessagingService has terminated the accept() thread
2017-10-23 20:06:33,134 [StorageServiceShutdownHook] INFO - Paused
hints dispatch

Can some one able to put some light on this issue, will be a great help.

thanks in advance,

- regards


View raw message