cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shalom sagges <shalomsag...@gmail.com>
Subject User Defined Compaction Issue
Date Mon, 25 Sep 2017 18:10:49 GMT
Hi Everyone,

I'm running into an issue I can't seem to Solve.

I execute force compaction in order to reclaim back storage.
Everything was working fine for a time, but after a while I found that
tombstones aren't being removed any longer.

For example, I've compacted the following SSTable:
*21G *Sep 19 10:18 file-jb-69103-Data.db
Estimated droppable tombstones:

*0.9115601492568154*
I ran it with jmxterm and the compaction started and completed
successfully.
 $>run -b org.apache.cassandra.db:type=CompactionManager
forceUserDefinedCompaction file-jb-69103-Data.db
 #calling operation forceUserDefinedCompaction of mbean
org.apache.cassandra.db:type=CompactionManager
 #operation returns:
null


A new SStable was created, but no tombstones were removed.
 *21G *Sep 25 12:16 file-jb-71319-Data.db
 Estimated droppable tombstones:

* 0.9115601492568154*
I've tried running it from jconsole as well, but the outcome was the same.

Is anyone familiar with this issue?
Btw, this cluster is on version 2.0.14 .


Thanks!
Shalom

Mime
View raw message