cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Iliev <ivan.iliev.il...@gmail.com>
Subject Cassandra All host(s) tried for query failed (no host was tried)
Date Wed, 30 Aug 2017 15:10:51 GMT
Hello everyone,

We are using Cassandra 3.9 for storing quite a lot of data produced from
our tester machines.

Occasionally, we are seeing issues with apps not being able to communicate
with Cassandra nodes, returning the following errors (captured in
servicemix logs):

>  by: com.datastax.driver.core.exceptions.NoHostAvailableException: All
> host(s) tried for query failed (no host was tried)
> at
> com.datastax.driver.core.RequestHandler.reportNoMoreHosts(RequestHandler.java:218)
> at
> com.datastax.driver.core.RequestHandler.access$1000(RequestHandler.java:43)
> at
> com.datastax.driver.core.RequestHandler$SpeculativeExecution.sendRequest(RequestHandler.java:284)
> at
> com.datastax.driver.core.RequestHandler.startNewExecution(RequestHandler.java:115)
> at
> com.datastax.driver.core.RequestHandler.sendRequest(RequestHandler.java:91)
> at
> com.datastax.driver.core.SessionManager.executeAsync(SessionManager.java:132)
> ... 107 more


As a result, apps that try to send data to cassandra get crashed due to
running out of memory and we have to restart the containers in which they
run.

So far I have not been able to identify what might be the cause for this as
nothing (at least I could not find anything relevant on the timestamps) in
the cassandra debug and system logs.

Could you share some insight on this ? What to check and where to start
from , in order to troubleshoot this.

Thanks !
Ivan

Mime
View raw message