cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amir Shahinpour <a...@holisticlabs.net>
Subject Re: Conection refuse
Date Tue, 29 Aug 2017 21:01:41 GMT
Hi Lucas,

Thanks for your response. So I checked the system.log and I found the
following error at the end which I think is causing the problem.

Fatal exception during initialization
org.apache.cassandra.exceptions.ConfigurationException: Found system
keyspace files, but they couldn't be loaded!

It could be due to removing some of the data. I ran the following command
to remove some data. sudo rm -rf /var/lib/cassandra/*

I am new to Cassandra and I think I made a mistake. So I had only one node
which was working fine with my tables that I had. I wanted to add a second
node and start using the real power of Cassandra. So I follow one of post
that I found, there were some changes in cassandra.yaml file and
afterwards I had to remove the files and that's why I run the remove
command. So right now neither of CQLSH and nodetool works. Please let me
know if you need any other information.

Here is a screenshot of the system.log. Thanks a lot for your help.

Best,
Amir

[image: Inline image 1]

On Tue, Aug 29, 2017 at 7:17 AM, Lucas Benevides <
lucas@maurobenevides.com.br> wrote:

> Hello Amir,
>
> You should see the log. If it was installed by the apt-get tool, it should
> be in /var/log/cassandra/system.log.
> It can occur when the schema of the node you are trying to connect is out
> of date with the cluster.
> How many nodes are there in you cluster?
> What is the output of "nodetool describecluster"?
>
> Best regards,
> Lucas Benevides
>
> 2017-08-28 19:45 GMT-03:00 Amir Shahinpour <amir@holisticlabs.net>:
>
>> Hi,
>>
>> I am getting an error connecting to cqlsh. I am getting the following
>> error.
>>
>> Connection error: ('Unable to connect to any servers', {'127.0.0.1':
>> error(111, "Tried connecting to [('127.0.0.1', 9042)]. Last error:
>> Connection refused")})
>>
>> I change the Cassandra.yaml file setting for rpc_address to my ip address
>> and listen_address to localhost.
>>
>>
>> listen_address: localhost
>> rpc_address: my_IP
>>
>> I also tried to change the cassandra-env.sh  to add my IP address but
>> still same error.
>>
>> JVM_OPTS="$JVM_OPTS -Djava.rmi.server.hostname=my_IP"
>>
>> Any suggestion?
>>
>>
>>
>>
>

Mime
View raw message