cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From piet molenaar <piet....@gmail.com>
Subject java.lang.UnsatisfiedLinkError on CentOS 6.5 VM
Date Fri, 28 Jul 2017 14:31:31 GMT
Hi, I've installed Cassandra on a CentOS cluster of VM's

When starting up Cassandra gives OK but when actually checking the nodetool
status this gives a connection error, and when checking Cassandra is in
fact not running at all.

The log shows problems:
ERROR [main] 2017-07-28 14:03:56,958 NativeLibraryLinux.java:62 - Failed to
link the C library against JNA. Native methods will be unavailable.
java.lang.UnsatisfiedLinkError:
/tmp/jna-3506402/jna7194809249311751737.tmp: /lib64/libc.so.6: version
`GLIBC_2.14' not found (required by
/tmp/jna-3506402/jna7194809249311751737.tmp)

The same happened with the binary. Looking the library up in the CentOS
community this is till EOL of series 6.X restricted to version glibc_2.12

Any ideas how to circumvent this or should I use an older version of
Cassandra?

Regards,
Piet


-- 
Piet Molenaar
piet.amc@gmail.com
Department of Oncogenomics, M1-131
Academic Medical Center
University of Amsterdam
Meibergdreef 9
1105 AZ Amsterdam
the Netherlands

tel (+31) 20-5666592
fax (+31) 20-6918626

Mime
View raw message