cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martijn Pieters <mjpiet...@fb.com>
Subject Re: IPv6-only host, can't seem to get Cassandra to bind to a public port
Date Tue, 11 Apr 2017 14:29:10 GMT
From: sai krishnam raju potturi <pskraju88@gmail.com>
> I got a similar error, and commenting out the below line helped.
> JVM_OPTS="$JVM_OPTS -Djava.net.preferIPv4Stack=true"
>
> Did you also include "rpc_interface_prefer_ipv6: true" in the YAML file?

No luck at all here. Yes, I had commented out that line (and also tried replacing it with
`-Djava.net.preferIPv6Addresses=true`, included in my email. I also included an error to make
sure it was the right file).

It all *should* work, but doesn’t. :-(

I just tried again with “rpc_interface_prefer_ipv6: true” set as well, but without luck.
I note that I have the default “rpc_address: localhost”, so it’ll bind to the lo loopback,
which has IPv4 configured already. Not that using “rpc_address: ‘::1’” instead works
(same error, so I can’t bind to the IPv6 localhost address either).

Martijn Pieters




Mime
View raw message