cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From I PVP <i...@hotmail.com>
Subject Re: /etc/init.d/cassandra for RHEL
Date Wed, 29 Mar 2017 12:28:42 GMT
This one worked fine
https://blog.tomas.cat/sites/default/files/cassandra.initd





On March 29, 2017 at 2:17:17 AM, I PVP (ipvp@hotmail.com<mailto:ipvp@hotmail.com>) wrote:

i tried using the https://github.com/apache/cassandra/blob/trunk/redhat/cassandra
won’t start using my own values and it is not generating logs  at all.

had you ever saw this behavior before?

JAVA_HOME is properly set
the user and group cassandra exist
cassandra:cassandra  is the owner of the /opt/cassandra/*

….
export CASSANDRA_HOME=/opt/cassandra
export CASSANDRA_CONF=/opt/cassandra/conf
export CASSANDRA_INCLUDE=/opt/cassandra/bin/cassandra.in.sh
export CASSANDRA_OWNR=cassandra
NAME="cassandra"
log_file=/opt/cassandra/log/cassandra.log
pid_file=/opt/cassandra/cassandra.pid
lock_file=/opt/cassandra/cassandra.lock
CASSANDRA_PROG=/opt/cassandra/bin/cassandra
….

it starts only by doing  "sudo /opt/cassandra/bin/cassandra -fR”


thanks for your help

IPVP


On March 29, 2017 at 12:57:50 AM, Michael Shuler (michael@pbandjelly.org<mailto:michael@pbandjelly.org>)
wrote:

On 03/28/2017 10:53 PM, Michael Shuler wrote:
> On 03/28/2017 09:36 PM, I PVP wrote:
>> any recommend /etc/init.d/cassandra for RHEL when installing it from
>> apache-cassandra-3.10-bin.tar.gz ?
>>
>> i goggled it but could not find anything that seems to be "proven"
>>
>
> https://github.com/apache/cassandra/blob/trunk/redhat/cassandra
>

That was probably a little too brief. The paths will need to be
modified, if you are running from a tarball. Easier would be to build
the rpm packages and install - see the README.md in the redhat directory:

https://github.com/apache/cassandra/tree/trunk/redhat

Check out the release tag you want, `git checkout cassandra-3.10` for
example, and build the rpms. This will install the init for your and put
all the pieces in the expected places.

--
Kind regards,
Michael
Mime
View raw message