cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajesh Radhakrishnan <Rajesh.Radhakrish...@phe.gov.uk>
Subject RE: cqlsh fails to connect
Date Fri, 28 Oct 2016 15:53:24 GMT

Hi John Z,

Did you tried running with latest Python 2.7.11 or 2.7.12?

Kind regards,
Rajesh Radhakrishnan

________________________________
From: Ioannis Zafiropoulos [johnzaf@gmail.com]
Sent: 27 October 2016 22:16
To: user@cassandra.apache.org
Subject: cqlsh fails to connect

I upgraded DSE 4.8.9 to 5.0.3, that is, from Cassandra 2.1.11 to 3.0.9
I used DSE 5.0.3 tarball installation. Cassandra cluster is up and running OK and I am able
to connect through DBeaver.

Tried a lot of things and cannot connect with cqlsh:

Connection error: ('Unable to connect to any servers', {'x.x.x.x': UnicodeDecodeError('utf8',
'+\x00\x00H\x08\x00\xf0$+\x00\x00\x10\x7f-\xe7S+\x00\x00`B\xb3\xe5S', 6, 7, 'invalid continuation
byte')})

Versions
------------
$ pip freeze | grep cas
cassandra-driver==3.6.0
cassandra-driver-dse==1.0.3

$ python
Python 2.7.5 (default, Nov 20 2015, 02:00:19)
[GCC 4.8.5 20150623 (Red Hat 4.8.5-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.

$ cat /etc/redhat-release
CentOS Linux release 7.2.1511 (Core)

$ which cqlsh (DSE's cqlsh client)
/opt/dse/bin/cqlsh

Tried also
$ export CQLSH_NO_BUNDLED=false

Also tried
--------------
Tried to install via pip in a fresh clean box the cqlsh client. I ended up with the latest
cassandra-driver 3.7.1

$ pip freeze | grep cas
cassandra-driver==3.7.1

$ pip freeze | grep cql
cql==1.4.0
cqlsh==5.0.3

And got this:
Connection error: ('Unable to connect to any servers', {'x.x.x.x': ProtocolError("cql_version
'3.3.1' is not supported by remote (w/ native protocol). Supported versions: [u'3.4.0']",)})

Tried to force it:
$ cqlsh XX.XX.XX.XX --cqlversion="3.4.0"
Got the original-first error message:
Connection error: ('Unable to connect to any servers', {'x.x.x.x': UnicodeDecodeError('utf8',
'+\x00\x00H\x08\x00\xf0$+\x00\x00\x10\x7f-\xe7S+\x00\x00`B\xb3\xe5S', 6, 7, 'invalid continuation
byte')})

At some point I got this message too, but I don't remember what I did:
Connection error: ('Unable to connect to any servers', {'x.x.x.x': DriverException(u'Failed
decoding result column "table_name" of type varchar: ',)})

Thank you in advance for you help,
John Z





**************************************************************************
The information contained in the EMail and any attachments is confidential and intended solely
and for the attention and use of the named addressee(s). It may not be disclosed to any other
person without the express authority of Public Health England, or the intended recipient,
or both. If you are not the intended recipient, you must not disclose, copy, distribute or
retain this message or any part of it. This footnote also confirms that this EMail has been
swept for computer viruses by Symantec.Cloud, but please re-sweep any attachments before opening
or saving. http://www.gov.uk/PHE
**************************************************************************
Mime
View raw message