cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anishek Agarwal <anis...@gmail.com>
Subject handling down node cassandra 2.0.15
Date Mon, 16 Nov 2015 10:20:43 GMT
Hello,

We are having a 3 node cluster and one of the node went down due to a
hardware memory failure looks like. We followed the steps below after the
node was down for more than the default value of *max_hint_window_in_ms*

I tried to restart cassandra by following the steps @


   1.
   http://docs.datastax.com/en/cassandra/1.2/cassandra/operations/ops_replace_node_t.html
   2.
   http://blog.alteroot.org/articles/2014-03-12/replace-a-dead-node-in-cassandra.html

*except the "clear data" part as it was not specified in second blog above.*

i was trying to restart the same node that went down, however I did not get
the messages in log files as stated in 2 against "StorageService"

instead it just tried to replay and then stopped with the error message as
below:

*ERROR [main] 2015-11-16 15:27:22,944 CassandraDaemon.java (line 584)
Exception encountered during startup*
*java.lang.RuntimeException: Cannot replace address with a node that is
already bootstrapped*

Can someone please help me if there is something i am doing wrong here.

Thanks for the help in advance.

Regards,
Anishek

Mime
View raw message