cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lijun Huang <coder...@gmail.com>
Subject Re: which astyanax version to use?
Date Wed, 18 Nov 2015 05:04:20 GMT
Thank you Minh,

So it means if I want to use Cassandra 2.1+, any version of Astyanax cannot
be compatible with it? Because we are already using the Astyanax, it maybe
a heavy work to change from Astyanax  to Datastax Java Driver.



On Wed, Nov 18, 2015 at 11:52 AM, Minh Do <mdo@netflix.com> wrote:

> The latest version of Astyanax won't work with Cassandra 2.1+.  So you are
> better off using Java Driver from Datastax.
>
> /Minh
>
> On Tue, Nov 17, 2015 at 7:29 PM, Lijun Huang <coderhlj@gmail.com> wrote:
>
>> Hi All,
>>
>> I have the similar problem, if I use the Cassandra 2.1 version, which
>> Astyanax version is the best one for me? For the versions in Astyanax
>> Github pages make me a little confused, I need some experience about this.
>> Thanks in advance.
>>
>> Thanks,
>> Lijun Huang
>>
>>
>> ------------------ Original ------------------
>> *From: * "Lu, Boying";<Boying.Lu@emc.com>;
>> *Date: * Mon, Nov 9, 2015 04:56 PM
>> *To: * "user@cassandra.apache.org"<user@cassandra.apache.org>;
>> *Subject: * which astyanax version to use?
>>
>> Hi, All,
>>
>>
>>
>> We plan to upgrade Cassandra from 2.0.17 to 2.1.11 (the latest stable
>> release recommended to be used in the product environment) in our product.
>>
>> Currently we are using Astyanax 1.56.49 as Java client, I found there are
>> many new Astyanax at https://github.com/Netflix/astyanax/releases
>>
>> So which version should we use in a product environment 3.8.0?
>>
>>
>>
>> Thanks
>>
>>
>> Boying
>>
>>
>>
>
>


-- 
Best regards,
Lijun Huang

Mime
View raw message