cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anuj Wadehra <anujw_2...@yahoo.co.in>
Subject Re: handling down node cassandra 2.0.15
Date Mon, 16 Nov 2015 18:10:31 GMT
Hi Abhishek,
In my opinion, you already have data and bootstrapping is not needed here. You can set auto_bootstrap
to false in Cassandra.yaml and once the cassandra is rebooted, you should run repair to fix
the inconsistent data.

ThanksAnuj
 


     On Monday, 16 November 2015 10:34 PM, Josh Smith <josh.smith@careerbuilder.com>
wrote:
   

 #yiv1301064707 -- filtered {font-family:Helvetica;panose-1:2 11 6 4 2 2 2 2 2 4;}#yiv1301064707
filtered {panose-1:2 4 5 3 5 4 6 3 2 4;}#yiv1301064707 filtered {font-family:Calibri;panose-1:2
15 5 2 2 2 4 3 2 4;}#yiv1301064707 filtered {font-family:Consolas;panose-1:2 11 6 9 2 2 4
3 2 4;}#yiv1301064707 p.yiv1301064707MsoNormal, #yiv1301064707 li.yiv1301064707MsoNormal,
#yiv1301064707 div.yiv1301064707MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:12.0pt;}#yiv1301064707
a:link, #yiv1301064707 span.yiv1301064707MsoHyperlink {color:blue;text-decoration:underline;}#yiv1301064707
a:visited, #yiv1301064707 span.yiv1301064707MsoHyperlinkFollowed {color:purple;text-decoration:underline;}#yiv1301064707
p {margin-right:0in;margin-left:0in;font-size:12.0pt;}#yiv1301064707 pre {margin:0in;margin-bottom:.0001pt;font-size:10.0pt;}#yiv1301064707
span.yiv1301064707EmailStyle18 {color:#1F497D;}#yiv1301064707 span.yiv1301064707HTMLPreformattedChar
{}#yiv1301064707 .yiv1301064707MsoChpDefault {}#yiv1301064707 filtered {margin:1.0in 1.0in
1.0in 1.0in;}#yiv1301064707 div.yiv1301064707WordSection1 {}#yiv1301064707 filtered {}#yiv1301064707
ol {margin-bottom:0in;}#yiv1301064707 ul {margin-bottom:0in;}#yiv1301064707 Sis you set the
JVM_OPTS to replace address? That is usually the error I get when I forget to set the replace_address
on Cassandra-env.    JVM_OPTS="$JVM_OPTS -Dcassandra.replace_address=address_of_dead_node
      From: Anishek Agarwal [mailto:anishek@gmail.com]
Sent: Monday, November 16, 2015 9:25 AM
To: user@cassandra.apache.org
Subject: Re: handling down node cassandra 2.0.15    nope its not    On Mon, Nov 16, 2015
at 5:48 PM, sai krishnam raju potturi <pskraju88@gmail.com> wrote: 
Is that a seed node?    On Mon, Nov 16, 2015, 05:21 Anishek Agarwal <anishek@gmail.com>
wrote: 
Hello,    We are having a 3 node cluster and one of the node went down due to a hardware
memory failure looks like. We followed the steps below after the node was down for more than
the default value of max_hint_window_in_ms     I tried to restart cassandra by following
the steps @       
   - http://docs.datastax.com/en/cassandra/1.2/cassandra/operations/ops_replace_node_t.html
   - http://blog.alteroot.org/articles/2014-03-12/replace-a-dead-node-in-cassandra.html
 except the "clear data" part as it was not specified in second blog above.    i was trying
to restart the same node that went down, however I did not get the messages in log files as
stated in 2 against "StorageService"    instead it just tried to replay and then stopped
with the error message as below:    ERROR [main] 2015-11-16 15:27:22,944 CassandraDaemon.java
(line 584) Exception encountered during startup java.lang.RuntimeException: Cannot replace
address with a node that is already bootstrapped    Can someone please help me if there is
something i am doing wrong here.     Thanks for the help in advance.     Regards, Anishek 


   

  
Mime
View raw message