cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nate McCall <n...@thelastpickle.com>
Subject Re: AWS multi-region DCs fail to rebuild
Date Thu, 30 Jul 2015 20:25:05 GMT
>
>
> This happens repeatedly when attempting to run the rebuild on just a
> single node
> in the US DC (pointing at the EU DC). I have not yet tried any other node
> from the
> US DC.
>
> Is this a bug or a configuration error perhaps? I know people out there
> are using
> AWS for Cassandra - how are you replicating across regions?
>

There have been some edge cases here in the past:
https://issues.apache.org/jira/browse/CASSANDRA-4026

Check the AWS metadata (
http://docs.aws.amazon.com/AWSEC2/latest/UserGuide/ec2-instance-metadata.html)
to see that what the region and AZ endpoints return is consistent with your
keyspace declaration.

If nothing really sticks out, you may want to try just using GPFS and fall
back to setting DC and rack by hand.

Per Rob's point about bleeding edge, I'd be super curious if the existing
setup worked as is on 2.1 or 2.0. I'd be willing to bet you are the first
person trying to make EC2Snitch span regions on 2.2.


-- 
-----------------
Nate McCall
Austin, TX
@zznate

Co-Founder & Sr. Technical Consultant
Apache Cassandra Consulting
http://www.thelastpickle.com

Mime
View raw message