cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ZeroUno <zerozerouno...@gmail.com>
Subject Re: sstableloader usage doubts
Date Fri, 05 Jun 2015 13:31:58 GMT
Il 04/06/15 17:17, Sebastian Estevez ha scritto:

> If you have all the sstables for each node and no token range changes,
> you can just move the sstables to their spot in the data directory
> (rsync or w/e) and bring up your nodes. If you're already up you can use
> nodetool refresh to load the sstables.

Hi, as previously described, in my situation I have the sstables for 
only TWO of my four nodes, i.e. I have a backup of one datacenter only.

I tried stopping cassandra on all four nodes, copying the sstables to 
their original location on the two nodes for which I have a backup, and 
restarting cassandra on all four nodes, but the data did not propagate 
to the second datacenter: the two nodes were I restored the backup 
appeared to be OK, but the two nodes in the other datacenter remained empty.
Am I missing anything?

Also, I tried nodetool refresh with no success.
First of all, on which nodes should I run it?
I tried running it on the nodes were I restored the sstables, but it 
exited without any output and in the log I could see "No new SSTables 
were found for <mykeyspace>/<mytablename>", it didn't do anything.
I'm pretty sure I restored the data in the right place, not in the 
snapshot subdirs.

Thanks.

-- 
01


Mime
View raw message