cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anton Koshevoy <>
Subject Re: Restoring all cluster from snapshots
Date Tue, 09 Jun 2015 13:32:01 GMT
Ok, new sequence:
- rm -rf /db/cassandra/cr/data0*/system/*
- /etc/init.d/cassandra start
- cqlsh -f schema(here is the schema for cr_production keyspace only)
- /etc/init.d/cassandra restart

I see the new keyspace, but it’s empty:

cqlsh> describe keyspaces;

system_traces  cr_production  system

cqlsh> use cr_production ;
cqlsh:cr_production> select * from cr_production.url_cs ;

 id | ct | d_id

(0 rows)

|/ State=Normal/Leaving/Joining/Moving
--  Address       Load       Tokens  Owns    Host ID                  
UN   74.35 KB   256     ?       7fc4f832-9d98-4bfd-81fb-0c361bff487d
UN  86.46 KB   256     ?       782d450d-50d5-4738-a654-bf7398557842

Note: Non-system keyspaces don't have the same replication settings, effective ownership information
is meaningless

then I tried:

- nodetool refresh -- cr_production url_cs

with the same result.

On June 9, 2015 at 1:29:36 AM, Robert Coli ( wrote:

On Mon, Jun 8, 2015 at 2:52 PM, Sanjay Baronia <> wrote:
Yes, you shouldn’t delete the system directory. Next steps are …reconfigure the test
cluster with new IP addresses, clear the gossiping information and then boot the test cluster.

If you don't delete the system directory, you run the risk of the test cluster nodes joining
the source cluster.

Just start a single node on the new cluster, empty, and create the schema on it.

Then do the rest of the process.

View raw message