cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vanessa Gligor <vanessagli...@gmail.com>
Subject Re: DataStax Enterprise Amazon AMI Launch Error
Date Mon, 16 Mar 2015 06:55:46 GMT
I have used m3.medium and m3.large

On Sat, Mar 14, 2015 at 2:36 AM, Patrick McFadin <pmcfadin@gmail.com> wrote:

> What size of instance are you using? It looks like you aren't at to get
> resources set up in time.
>
>
> On Thursday, March 12, 2015, Vanessa Gligor <vanessagligor@gmail.com>
> wrote:
>
>> When I try to launch an EC2 Instance using DataStax community it's
>> working, so I have the premission to create an EC2 instance. I want to have
>> Cassandra and Solr as services installed on an VM.
>>
>> Thanks!
>>
>> On Thu, Mar 12, 2015 at 2:56 PM, Ali Akhtar <ali.rac200@gmail.com> wrote:
>>
>>> Seems like its having trouble launching the other EC2 instances that
>>> you're requesting. You would need to provide it your AWS credentials for an
>>> account that has the permissions to create EC2 instances. Have you done
>>> that?
>>>
>>> If you just want to install cassandra on AWS, you might find this bash
>>> script useful: https://gist.github.com/aliakhtar/3649e412787034156cbb
>>>
>>> On Thu, Mar 12, 2015 at 5:14 PM, Vanessa Gligor <vanessagligor@gmail.com
>>> > wrote:
>>>
>>>> I'm trying to launch a new instance of DataStax AMI on a EC2 Amazon
>>>> instance. I tried this in 2 different regions (us-east and eu-west), using
>>>> these AMIs: ami-ada2b6c4, ami-814ec2e8 (us-east) and ami-7f33cd08,
>>>> ami-b2212dc6 (eu-west).
>>>>
>>>> I followed this documentation:
>>>> http://www.datastax.com/documentation/datastax_enterprise/4.6/datastax_enterprise/install/installAMI.html
>>>>
>>>> So this is what I've done so far:
>>>>
>>>> 1. I've created a new security group (with those specific ports - I
>>>> cannot upload the print screen because I have just created this account)
>>>>
>>>> 2. I've create a new key pair
>>>>
>>>> 3. I've launched the DataStax AMI with these configuration details:
>>>> --clustername cluster --totalnodes 4 --version enterprise --username
>>>> my_name --password my_password --searchnodes 2 (I have verified my
>>>> credentials - I can login here http://debian.datastax.com/enterprise/ )
>>>>
>>>> 4. After selecting the previous created security group & key pair I
>>>> launched the instance
>>>>
>>>> 5. I've connected to my DataStax Enterprise EC2 instance and this is
>>>> the displayed log:
>>>>
>>>> Cluster started with these options: --clustername cluster --totalnodes
>>>> 4 --version enterprise --username my_name --password **** --searchnodes 2
>>>>
>>>> 03/12/15-08:59:23 Reflector: Received 1 of 2 responses from:
>>>> [u'172.31.34.171']... Exception seen in ds1_launcher.py. Please check
>>>> ~/datastax_ami/ami.log for more info. Please visit ....
>>>>
>>>>
>>>> and the ami.log shows these messages:
>>>>
>>>>
>>>> [INFO] 03/12/15-08:59:23 Reflector: Received 1 of 2 responses from: [u'172.31.34.171']
>>>> [ERROR] EC2 is experiencing some issues and has not allocated all of the
resources in under 10 minutes.
>>>> Aborting the clustering of this reservation. Please try again.
>>>> [ERROR] Exception seen in ds1_launcher.py:
>>>> Traceback (most recent call last):
>>>> File "/home/ubuntu/datastax_ami/ds1_launcher.py", line 22, in initial_configurations
>>>> ds2_configure.run()
>>>>  File "/home/ubuntu/datastax_ami/ds2_configure.py", line 1135, in run
>>>> File "/home/ubuntu/datastax_ami/ds2_configure.py", line 57, in exit_path
>>>> AttributeError: EC2 is experiencing some issues and has not allocated all
of the resources in under 10 minutes.
>>>> Aborting the clustering of this reservation. Please try again.
>>>>
>>>> Any suggestion on how to fix this problem?
>>>>
>>>> Thank you!
>>>>
>>>> Have a nice day,
>>>>
>>>> Vanessa.
>>>>
>>>>
>>>
>>

Mime
View raw message