cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clint Kelly <clint.ke...@gmail.com>
Subject Re: AMI to use to launch a cluster with OpsCenter on AWS
Date Sat, 21 Feb 2015 03:48:19 GMT
BTW I was able to use this script:

    https://github.com/joaquincasares/cassandralauncher

to get a cluster up and running pretty easily on AWS.  Cheers to the author
for this.

Still curious for answers to my questions above, but not as urgent.

Best regards,
Clint


On Fri, Feb 20, 2015 at 5:36 PM, Clint Kelly <clint.kelly@gmail.com> wrote:

> Hi all,
>
> I am trying to follow the instructions here for installing DSE 4.6 on AWS:
>
>
> http://www.datastax.com/documentation/datastax_enterprise/4.6/datastax_enterprise/install/installAMIOpsc.html
>
> I was successful creating a single-node instance running OpsCenter, which
> I intended to bootstrap creating a larger cluster running Cassandra and
> Spark.
>
> During my first attempt, however, OpsCenter reported problems talking to
> agents in the new cluster I was creating.  I ssh'ed into one of the new
> instances that I created with OpsCenter and saw that this was the problem:
>
> ------------------------------------
>
> DataStax AMI for DataStax Enterprise
>
> and DataStax Community
>
> AMI version 2.4
>
>
>
> ------------------------------------
>
> DataStax AMI 2.5 released 02.25.2014
>
> http://goo.gl/g1RRd7
>
>
> This AMI (version 2.4) will be left
>
> available, but no longer updated.
>
> ------------------------------------
>
>
>
> These notices occurred during the startup of this instance:
>
> [ERROR] 02/21/15-00:53:01 sudo chown -R cassandra:cassandra /mnt/cassandra:
>
> [WARN] Permissions not set correctly. Please run manually:
>
> [WARN] sudo chown -hR cassandra:cassandra /mnt/cassandra
>
> [WARN] sudo service dse restart
>
>
> It looks like by default, the OpsCenter GUI selects an out-of-date AMI
> (ami-4c32ba7c)
> when you click on "Create Cluster" and attempt to create a brand-new
> cluster on EC2.
>
> What is the recommended image to use here?  I found a version 2.5.1 of the
> autoclustering AMI (
> http://thecloudmarket.com/image/ami-ada2b6c4--datastax-auto-clustering-ami-2-5-1-hvm).
> Is that correct?  Or should I be using one of the regular AMIs listed at
> http://www.datastax.com/documentation/datastax_enterprise/4.6/datastax_enterprise/install/installAMIOpsc.html
> ?  Or just a standard ubuntu image?
>
> FWIW, I tried just using one of the AMIs listed on the DSE 4.6 page
> (ami-32f7c977), and I still see the "Waiting for the agent to start"
> message, although if I log in, things look like they have kind of worked:
>
> Cluster started with these options:
>
> None
>
>
> Raiding complete.
>
>
> Waiting for nodetool...
>
> The cluster is now in it's finalization phase. This should only take a
> moment...
>
>
> Note: You can also use CTRL+C to view the logs if desired:
>
>     AMI log: ~/datastax_ami/ami.log
>
>     Cassandra log: /var/log/cassandra/system.log
>
>
>
> Datacenter: us-west-2
>
> =====================
>
> Status=Up/Down
>
> |/ State=Normal/Leaving/Joining/Moving
>
> --  Address      Load       Tokens  Owns (effective)  Host ID
>                   Rack
>
> UN  10.28.24.19  51.33 KB   256     100.0%
>  ce0d365a-d58b-4700-b861-9f30af400476  2a
>
>
>
> Opscenter: http://ec2-54-71-102-180.us-west-2.compute.amazonaws.com:8888/
>
>     Please wait 60 seconds if this is the cluster's first start...
>
>
>
> Tools:
>
>     Run: datastax_tools
>
> Demos:
>
>     Run: datastax_demos
>
> Support:
>
>     Run: datastax_support
>
>
>
> ------------------------------------
>
> DataStax AMI for DataStax Enterprise
>
> and DataStax Community
>
> AMI version 2.5
>
> DataStax Community version 2.1.3-1
>
>
> ------------------------------------
>
>
>
> These notices occurred during the startup of this instance:
>
> [ERROR] 02/21/15-01:18:55 sudo chown opscenter-agent:opscenter-agent
> /var/lib/datastax-agent/conf:
>
> [ERROR] 02/21/15-01:19:04 sudo chown -R opscenter-agent:opscenter-agent
> /var/log/datastax-agent:
>
> [ERROR] 02/21/15-01:19:04 sudo chown -R opscenter-agent:opscenter-agent
> /mnt/datastax-agent:
>
>
> I would appreciate any help...  I assume what I'm trying to do here is
> pretty common.
>
>
>

Mime
View raw message