cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J. Ryan Earl" <...@jryanearl.us>
Subject Re: Setting up JNA on CentOS 6.6. with cassandra20-2.0.12 and Oracle Java 1.7.0_75
Date Wed, 25 Feb 2015 21:13:47 GMT
CentOS6 and every major version of C* from 1.1 through 2.1, but I would be
curious if there's maybe a memory leak or something fixed between 3.2.4 and
3.2.7...?  AFAIK, it's only use for memlocking the heap and creating
hardlinks for snapshots, both of which work.

On Wed, Feb 25, 2015 at 2:53 PM, Garret Pick <pickgr@whistle.com> wrote:

> Hi,
>
> On this page
>
>
> http://www.datastax.com/documentation/cassandra/2.0/cassandra/install/installJnaRHEL.html
>
> it says
>
> "Cassandra requires JNA 3.2.7 or later. Some Yum repositories may provide
> earlier versions"
>
> and at the bottom
>
> "If you can't install using Yum or it provides a version of the JNA
> earlier than 3.2.7, install as described in Installing the JNA from the JAR
> file."
>
> Which version of OS and Cassandra are you running?
>
> thanks,
> Garret
>
>
>
>
> On Wed, Feb 25, 2015 at 10:46 AM, J. Ryan Earl <oss@jryanearl.us> wrote:
> >
> > We've been using jna-3.2.4-2.el6.x86_64 with the Sun/Oracle JDK for
> probably 2-years now, and it works just fine.  Where are you seeing 3.2.7
> required at?  I searched the pages you link and that string isn't even in
> there.
> >
> > Regardless, I assure you the newest jna that ships in the EL6 repo works
> without issues.
> >
> > On Wed, Feb 25, 2015 at 2:12 PM, Garret Pick <pickgr@whistle.com> wrote:
> >>
> >> Hello,
> >>
> >> I'm having problems getting cassandra to start with the configuration
> listed above.
> >>
> >> Yum wants to install 3.2.4-2.el6 of the JNA along with several other
> packages including java-1.7.0-openjdk
> >>
> >> The documentation states that a JNA version earlier that 3.2.7 should
> not be used, so the jar file should be downloaded and installed directly
> into C*'s lib directory per
> >>
> >>
> http://www.datastax.com/documentation/cassandra/2.0/cassandra/install/installJnaTar.html
> >>
> >> From /var/log/cassandra/system.log
> >>
> >> all I see is
> >>
> >>  INFO [main] 2015-02-25 20:06:10,202 CassandraDaemon.java (line 191)
> Classpath:
> /etc/cassandra/conf:/usr/share/cassandra/lib/antlr-3.2.jar:/usr/share/cassandra/lib/apache-cassandra-2.0.12.jar:/usr/share/cassandra/lib/apache-cassandra-clientutil-2.0.12.jar:/usr/share/cassandra/lib/apache-cassandra-thrift-2.0.12.jar:/usr/share/cassandra/lib/commons-cli-1.1.jar:/usr/share/cassandra/lib/commons-codec-1.2.jar:/usr/share/cassandra/lib/commons-lang3-3.1.jar:/usr/share/cassandra/lib/compress-lzf-0.8.4.jar:/usr/share/cassandra/lib/concurrentlinkedhashmap-lru-1.3.jar:/usr/share/cassandra/lib/disruptor-3.0.1.jar:/usr/share/cassandra/lib/guava-15.0.jar:/usr/share/cassandra/lib/high-scale-lib-1.1.2.jar:/usr/share/cassandra/lib/jackson-core-asl-1.9.2.jar:/usr/share/cassandra/lib/jackson-mapper-asl-1.9.2.jar:/usr/share/cassandra/lib/jamm-0.2.5.jar:/usr/share/cassandra/lib/jbcrypt-0.3m.jar:/usr/share/cassandra/lib/jline-1.0.jar:/usr/share/cassandra/lib/jna.jar:/usr/share/cassandra/lib/json-simple-1.1.jar:/usr/share/cassandra/lib/libthrift-0.9.1.jar:/usr/share/cassandra/lib/log4j-1.2.16.jar:/usr/share/cassandra/lib/lz4-1.2.0.jar:/usr/share/cassandra/lib/metrics-core-2.2.0.jar:/usr/share/cassandra/lib/netty-3.6.6.Final.jar:/usr/share/cassandra/lib/reporter-config-2.1.0.jar:/usr/share/cassandra/lib/servlet-api-2.5-20081211.jar:/usr/share/cassandra/lib/slf4j-api-1.7.2.jar:/usr/share/cassandra/lib/slf4j-log4j12-1.7.2.jar:/usr/share/cassandra/lib/snakeyaml-1.11.jar:/usr/share/cassandra/lib/snappy-java-1.0.5.jar:/usr/share/cassandra/lib/snaptree-0.1.jar:/usr/share/cassandra/lib/stress.jar:/usr/share/cassandra/lib/super-csv-2.1.0.jar:/usr/share/cassandra/lib/thrift-server-0.3.7.jar:/usr/share/cassandra/lib/jamm-0.2.5.jar
> >>
> >> and it never actually starts
> >>
> >> Note that JNA is in the classpath above and is when I remove it,
> cassandra starts successfully.
> >>
> >> I tried installing the DSE package and it looks like it wants to
> install the older 3.2.4 JNA as a dependency so there seems to be a
> discrepancy in documentation
> >>
> >> Per
> >>
> >>
> http://www.datastax.com/documentation/datastax_enterprise/4.6/datastax_enterprise/install/installRHELdse.html
> >>
> >> Note: JNA (Java Native Access) is automatically installed.
> >>
> >> thanks for any help,
> >> Garret
> >
> >
>

Mime
View raw message