cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arthur Zubarev" <>
Subject Re: Why "select count("*) from .." hangs ?
Date Wed, 26 Mar 2014 20:05:23 GMT
I faced the same nuance in my early days with C*, specifically I got RPC timeouts on selecting
data from CFs larger than 300 GB.

The typical remedy is to implement paging. So instead of using the CLI resort to a custom
built client app. 



From: shahab 
Sent: Wednesday, March 26, 2014 4:34 AM
Subject: Re: Why "select count("*) from .." hangs ?

Thanks for the hints. I got a better picture of how to deal with "count" queries.

On Tue, Mar 25, 2014 at 7:01 PM, Robert Coli <> wrote:

  On Tue, Mar 25, 2014 at 8:36 AM, shahab <> wrote:

    But after iteration 8,  (i.e. inserting  1500000 sensor data), the "select count(') ...)
 throws time-out exception and doesn't work anymore. I even tried  to execute "select count(*)..."
using Datastax DevCenter GUI, but I got same result.

  All operations in Cassandra are subject to (various) timeouts, which by default are in the
scale of single digit seconds.

  If you attempt to do an operation (such as aggregates across large numbers of large objects)
which cannot complete in this time, this is a strong indication that either your overall approach
is inappropriate or, at very least, that your buckets are too large.


View raw message