cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Shuler <>
Subject Re: Cassandra DSC 2.0.5 not starting - "* could not access pidfile for Cassandra"
Date Mon, 10 Mar 2014 23:03:32 GMT
On 03/10/2014 05:15 PM, Michael Shuler wrote:
> I did find a bug with the same behavior you described. I have no idea
> why someone *removed* the dependency on a functional JRE from the
> cassandra package - this is *not* the same Depends: line as the
> upstream OSS cassandra package

Quick follow-up on why this package deviates from the upstream deb 
package: this is done to prevent users from being force-installed the 
OpenJDK packages, since most users install the Oracle JRE from tar [0]. 
This installation of OpenJDK via package steps on the hand-installed 
java alternatives symlinks. I had assumed, incorrectly, that the 
cassandra package in the DSC repository was the identical package as in 
the Apache repository.


Kind regards,

View raw message