cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edward Capriolo <>
Subject Re: Performance problem with large wide row inserts using CQL
Date Thu, 20 Feb 2014 13:16:40 GMT
For what it is worth you schema is simple and uses compact storage. Thus
you really dont need anything in cassandra 2.0 as far as i can tell. You
might be happier with a stable release like 1.2.something and just hector
or astyanax. You are really dealing with many issues you should not have to
just to protoype a simple cassandra app.

On Thursday, February 20, 2014, Sylvain Lebresne <>
> On Wed, Feb 19, 2014 at 9:38 PM, Rüdiger Klaehn <> wrote:
>> I have cloned the cassandra repo, applied the patch, and built it. But
when I want to run the bechmark I get an exception. See below. I tried with
a non-managed dependency to
cassandra-driver-core-2.0.0-rc3-SNAPSHOT-jar-with-dependencies.jar, which I
compiled from source because I read that that might help. But that did not
make a difference.
>> So currently I don't know how to give the patch a try. Any ideas?
>> cheers,
>> Rüdiger
>> Exception in thread "main" java.lang.IllegalArgumentException:
replicate_on_write is not a column defined in this metadata
>>     at
>>     at
>>     at com.datastax.driver.core.Row.getBool(
>>     at
>>     at
>>     at
>>     at com.datastax.driver.core.Metadata.rebuildSchema(
>>     at
>>     at
>>     at
>>     at
>>     at com.datastax.driver.core.Cluster$Manager.init(
>>     at
>>     at
>>     at com.datastax.driver.core.Cluster.connect(
>>     at
>>     at scala.Function0$class.apply$mcV$sp(Function0.scala:40)
>>     at
>>     at scala.App$$anonfun$main$1.apply(App.scala:71)
>>     at scala.App$$anonfun$main$1.apply(App.scala:71)
>>     at scala.collection.immutable.List.foreach(List.scala:318)
>>     at
>>     at scala.App$class.main(App.scala:71)
>>     at
>>     at
> I believe you've tried the cassandra trunk branch? trunk is basically the
future Cassandra 2.1 and the driver is currently unhappy because the
replicate_on_write option has been removed in that version. I'm supposed to
have fixed that on the driver 2.0 branch like 2 days ago so maybe you're
also using a slightly old version of the driver sources in there? Or maybe
I've screwed up my fix, I'll double check. But anyway, it would be overall
simpler to test with the cassandra-2.0 branch of Cassandra, with which you
shouldn't run into that.
> --
> Sylvain

Sorry this was sent from mobile. Will do less grammar and spell check than

View raw message