cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Coli <>
Subject Re: upgrade from cassandra 1.2.3 -> 1.2.13 + start using SSL
Date Wed, 08 Jan 2014 18:24:04 GMT
On Wed, Jan 8, 2014 at 1:17 AM, Jiri Horky <> wrote:

> I am specifically interested whether is possible to upgrade just one
> node and keep it running like that for some time, i.e. if the gossip
> protocol is compatible in both directions. We are a bit afraid to
> upgrade all nodes to 1.2.13 at once in a case we would need to rollback.

This not not officially supported. It will probably work for these
particular versions, but it is not recommended.

The most serious potential issue is an inability to replace the new node if
it fails. There's also the problem of not being able to repair until you're
back on the same versions. And other, similar, undocumented edge cases...


View raw message