cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Coli <rc...@eventbrite.com>
Subject Re: Unable to handshake with earlier version
Date Thu, 09 Jan 2014 18:32:33 GMT
On Thu, Jan 9, 2014 at 8:33 AM, Elliot Sumner <elliots@playdemand.com>wrote:

>
> I seem to be having a similar issue to
> https://www.mail-archive.com/user@cassandra.apache.org/msg33340.html
>
> Basically I have a new node of version 1.2.13, when attempting to connect
> to the ring it fails to handshake with other nodes in the cluster.
> This is attempting to connect to a 1.1.12 node.
>

Bootstrapping between different versions is not supported, if I'm correctly
understanding what you're trying to do. I'm surprised it doesn't work
between those versions, but generally it is recommended to bootstrap any
new nodes and THEN upgrade (all nodes) to the new version.

=Rob

Mime
View raw message