cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Turi, Ferenc (GE Power & Water, Non-GE)" <>
Subject RE: Intermittent connection error
Date Thu, 21 Nov 2013 19:26:12 GMT

Please attach the source to have deeper look at it.


From: Robert Wille []
Sent: Thursday, November 21, 2013 7:11 PM
Subject: Intermittent connection error

I intermittently get the following error when I try to execute my first query after connecting:

Caused by: com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried
for query failed (no host was tried)
                at com.datastax.driver.core.exceptions.NoHostAvailableException.copy(
                at com.datastax.driver.core.ResultSetFuture.extractCauseFromExecutionException(
                at com.datastax.driver.core.ResultSetFuture.getUninterruptibly(
                at com.datastax.driver.core.Session.execute(
                at com.datastax.driver.core.Session.execute(

The odd part is the "(no host was tried)". I definitely have provided it with a host, since
this exact same code works most of the time.

I don't know if this might be related to a question I posted earlier, which I haven't been
able to resolve yet. Whenever I issue a truncate command, I get the error "Unable to complete
request: one or more nodes were unavailable".

I've got a single node with all empty tables. It is definitely up and available, since most
of the time I can connect and do stuff (except truncate, which I can never do).

The only thing in the logs that looks relevant is this:

INFO [HANDSHAKE-/] 2013-11-20 11:36:59,064 (line
386) Handshaking version with /
INFO [HANDSHAKE-/] 2013-11-20 11:37:04,064 (line
395) Cannot handshake version with /

I'm running Cassandra 2.0.2.

Any help would be most appreciated.



View raw message