cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiller, Dean" <>
Subject Re: cassandra 1.2.6 -> Start key's token sorts after end token
Date Tue, 23 Jul 2013 12:06:00 GMT
Out of curiosity, what version of hadoop are you using with cassandra?  I think we are trying
0.20.2 if I remember(I have to ask my guy working on it to be sure).  I do remember him saying
the cassandra maven dependency was odd in that it is in the older version and not a newer
hadoop version.

We are using RandomPartitioner though right now which I have personally used in the past with
success.  We are in the process of map/reducing to a cassandra with MurmurPartitioner  (our
real reason to map/reduce is some refactorings in our model though and we just thought we
would switch to murmur).

Has anyone else used map/reduce with murmur partitioner?


From: Marcelo Elias Del Valle <<>>
Reply-To: "<>" <<>>
Date: Monday, July 22, 2013 4:04 PM
To: "<>" <<>>
Subject: cassandra 1.2.6 -> Start key's token sorts after end token


    I am trying to figure what might be cause this error. I am using Cassandra 1.2.6 (tried
with 1.2.3 as well) and I am trying to read data from cassandra on hadoop using column family
input format. I also got the same error using pure astyanax on a test.
    I am using Murmur3Partitioner and I created the keyspace using Cassandra 1.2.6, there
is nothing from prior versions. I created the keyspace with SimpleStrategy and replication
factor 1.
    Here is the exception I am getting:
2013-07-22 21:53:05,824 WARN org.apache.hadoop.mapred.Child (main): Error running child
java.lang.RuntimeException: InvalidRequestException(why:Start key's token sorts after end
at org.apache.cassandra.hadoop.ColumnFamilyRecordReader$WideRowIterator.maybeInit(
at org.apache.cassandra.hadoop.ColumnFamilyRecordReader$WideRowIterator.computeNext(
at org.apache.cassandra.hadoop.ColumnFamilyRecordReader$WideRowIterator.computeNext(
at org.apache.cassandra.hadoop.ColumnFamilyRecordReader.getProgress(
at org.apache.hadoop.mapred.MapTask$NewTrackingRecordReader.getProgress(
at org.apache.hadoop.mapred.MapTask$NewTrackingRecordReader.nextKeyValue(
at org.apache.hadoop.mapreduce.MapContext.nextKeyValue(
at org.apache.hadoop.mapred.MapTask.runNewMapper(
at org.apache.hadoop.mapred.Child$
at Method)
at org.apache.hadoop.mapred.Child.main(
Caused by: InvalidRequestException(why:Start key's token sorts after end token)
at org.apache.cassandra.thrift.Cassandra$
at org.apache.thrift.TServiceClient.receiveBase(
at org.apache.cassandra.thrift.Cassandra$Client.recv_get_paged_slice(
at org.apache.cassandra.thrift.Cassandra$Client.get_paged_slice(
at org.apache.cassandra.hadoop.ColumnFamilyRecordReader$WideRowIterator.maybeInit(
... 16 more
2013-07-22 21:53:05,828 INFO org.apache.hadoop.mapred.Task (main): Runnning cleanup for the

     Any hint?

Best regards,
Marcelo Elias Del Valle - @mvallebr

View raw message