cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiller, Dean" <>
Subject Re: 13k pending compaction tasks but ZERO running?
Date Thu, 14 Mar 2013 15:36:00 GMT
Duh me.  I forgot to mention I ran "nodetool compact <k> <cf>" and it was
done in 45 seconds and I still had a 36G file(darn, I am usually better
about putting the detail in my emailsŠI thought I added that).  I also
went into JMX and then did it there.

I ran it again and it took 15 seconds.  My script is as follows so that I
know the timesŠit's too bad nodetool doesn't log times for all tools they
have.  If I have time, I should just do a pull request on that.


date > compacttimes.txt
nodetool compact databus5 nreldata >> compacttimes.txt
date >> compacttimes.txt


On 3/14/13 9:26 AM, "Michael Theroux" <> wrote:

>Hi Dean,
>I saw the same behavior when we switched from STCS to LCS on a couple of
>our tables.  Not sure why it doesn't proceed immediately (I pinged the
>list, but didn't get any feedback).  However, running nodetool compact
><keyspace> <table> got things moving for me.
>On Mar 14, 2013, at 10:44 AM, Hiller, Dean wrote:
>> How do I get my node to run through the 13k pending compaction tasks?
>>I had to use iptables to take the ring out of the cluster for now and he
>>is my only node still on STCS.  In cassandra-cli, it shows LCS but on
>>disk, I see a 36Gig file(ie. Must be STCS still).  How can I get the 13k
>>pending tasks to start running?
>> Nodetool compactionstats Š.
>> pending tasks: 13793
>> Active compaction remaining time :        n/a
>> Thanks,
>> Dean

View raw message