cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiller, Dean" <>
Subject Re: disabling bloomfilter not working? or did I do this wrong?
Date Fri, 22 Feb 2013 19:59:48 GMT
Thanks, but I found out it is still running.  It looks like I have about a 5 hour wait left
for my upgradesstables(waited 4 hours already).  I will check the bloomfilter after that.

Out of curiosity, if I had much wider rows (ie. < 900k) per row, will compaction run faster(errrr…upgradesstables)
at all or would it basically run at the same speed.

I guess what I am wondering is 9 hours a normal compaction time for 130gb of data?


From: aaron morton <<>>
Reply-To: "<>" <<>>
Date: Friday, February 22, 2013 10:29 AM
To: "<>" <<>>
Subject: Re: disabling bloomfilter not working? or did I do this wrong?

Bloom Filter Space Used: 2318392048
Just to be sane do a quick check of the -Filter.db files on disk for this CF.
If they are very small try a restart on the node.

Number of Keys (estimate): 1249133696
Hey a billion rows on a node, what an age we live in :)


Aaron Morton
Freelance Cassandra Developer
New Zealand


On 23/02/2013, at 4:35 AM, "Hiller, Dean" <<>>

So in the cli, I ran

update column family nreldata with bloom_filter_fp_chance=1.0;

Then I ran

nodetool upgradesstables databus5 nreldata;

But my bloom filter size is still around 2gig(and I want to free up this heap)!!!! According
to nodetool cfstats command…

Column Family: nreldata
SSTable count: 10
Space used (live): 96841497731
Space used (total): 96841497731
Number of Keys (estimate): 1249133696
Memtable Columns Count: 7066
Memtable Data Size: 4286174
Memtable Switch Count: 924
Read Count: 19087150
Read Latency: 0.595 ms.
Write Count: 21281994
Write Latency: 0.013 ms.
Pending Tasks: 0
Bloom Filter False Postives: 974393
Bloom Filter False Ratio: 0.99998
Bloom Filter Space Used: 2318392048
Compacted row minimum size: 73
Compacted row maximum size: 446
Compacted row mean size: 143

View raw message