Deletes must be written to disk otherwise they are lost. 

Cheers

-----------------
Aaron Morton
Freelance Cassandra Developer
New Zealand

@aaronmorton

On 28/01/2013, at 3:29 AM, Kasun Weranga <kasunw@wso2.com> wrote:

Hi,

After running compaction tombstones get removed. So It seems like only setting GC grace seconds to lower value is not enough. Am I correct ?

Thanks,
Kasun

On Sun, Jan 27, 2013 at 1:31 PM, Kasun Weranga <kasunw@wso2.com> wrote:
Hi,

On Sun, Jan 27, 2013 at 12:05 AM, Michael Kjellman <mkjellman@barracuda.com> wrote:
What is your gc_grace set to?

Thanks for the info. 

I tried setting GcGraceSeconds for the column family to 0 since I have only one Cassandra node. still I can see the same behavior. 

    ColumnFamily: bam_phone_retail_store_kpi
      Key Validation Class: org.apache.cassandra.db.marshal.BytesType
      Default column value validator: org.apache.cassandra.db.marshal.BytesType
      Columns sorted by: org.apache.cassandra.db.marshal.BytesType
      GC grace seconds: 0
      Compaction min/max thresholds: 4/32
      Read repair chance: 0.0
      DC Local Read repair chance: 0.0
      Replicate on write: false
      Caching: KEYS_ONLY
      Bloom Filter FP chance: default
      Compaction Strategy: org.apache.cassandra.db.compaction.SizeTieredCompactionStrategy
      Compression Options:
        chunk_length_kb: 128
        sstable_compression: org.apache.cassandra.io.compress.SnappyCompressor


I am using Cassandra 1.1.3. Appreciate your help on solving this.

Thanks,
Kasun. 

 

Are your findings before or after this time after the deletion?

From: Kasun Weranga <kasunw@wso2.com>
Reply-To: "user@cassandra.apache.org" <user@cassandra.apache.org>
Date: Saturday, January 26, 2013 10:33 AM
To: "user@cassandra.apache.org" <user@cassandra.apache.org>, "dev@cassandra.apache.org" <dev@cassandra.apache.org>
Subject: Issue when deleting Cassandra rowKeys.

Hi all,

When I delete some rowkeys programmatically I can see two rowkeys remains in the column family. I think it is due to tombstones. Is there a way to remove it when deleting rowkeys. Can I run compaction programmatically after deletion? will it remove all these remaining rowkeys. 

Thanks,
Kasun.