cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergey Olefir <>
Subject Re: Multiple Data Center shows very uneven load
Date Tue, 11 Dec 2012 14:00:34 GMT
Keith Wright wrote
> I have base Cassandra 1.1.7 installed in two data centers with 3 nodes
> each using a PropertyFileSnitch as outlined below. When I run a nodetool
> ring, I see a very uneven load. Any idea what I could be going on? I have
> not added/removed any nodes or changed the replication scheme or counts.

I have a very similar issue myself and would love to know what (if anything)
needs to be done (I'm using 1.1.6 at the moment). After stress-test (maximum
load), I had the following on my nodes (every IP is changed to the
corresponding fake number):

This already shows uneven load despite the fact that nodes actually hold the
same amount of data (according to effective-ownership and application design
/ token values).

However I then proceeded to drop the single keyspace that was on this
cluster and I got this:

Why still has 700+ MB of data? I tried nodetool repair,
nodetool cleanup, and node restart (for -- none of that helped
(it still had those 700+ MB of data).

Here's info from the filesystem on that node:

And here is syslog from Cassandra when I restarted node:

I'd much appreciate if someone can provide some insight as to what is going
on and what (if anything) needs to be done.

Best regards,

View this message in context:
Sent from the mailing list archive at

View raw message