cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aaron morton <>
Subject Re: Losing keyspace on cassandra upgrade
Date Fri, 21 Sep 2012 08:39:59 GMT
Have you tried nodetool resetlocalschema on the 1.1.5 ?


Aaron Morton
Freelance Developer

On 20/09/2012, at 11:41 PM, Thomas Stets <> wrote:

> A follow-up:
> Currently I'm back on version 1.1.1.
> I tried - unsuccessfully - the following things:
> 1. Create the missing keyspace on the 1.1.5 node, then copy the files back into the data
> This failed, since the keyspace was already known on the other node in the cluster.
> 2. shut down the 1.1.1 node, that still has the keyspace. Then create the keyspace on
the 1.1.5 node.
> This failes since the node could not distribute the information through the cluster.
> 3. Restore the system keyspace from the snapshot I made before the upgrade.
> The restore seemed to work, but the node behaved just like after the update: it just
forgot my keyspace.
> Right now I'm at a loss on how to proceed. Any ideas? I'm pretty sure I can reproduce
the problem,
> so if anyone has an idea on what to try, or where to look, I can do some tests (within
> On Wed, Sep 19, 2012 at 4:43 PM, Thomas Stets <> wrote:
> I consistently keep losing my keyspace on upgrading from cassandra 1.1.1 to 1.1.5
> I have the same cassandra keyspace on all our staging systems:
> development:  a 3-node cluster
> integration: a 3-node cluster
> QS: a 2-node cluster
> (productive will be a 4-node cluster, which is as yet not active)
> All clusters were running cassandra 1.1.1. Before going productive I wanted to upgrade
to the
> latest productive version of cassandra.
> In all cases my keyspace disappeared when I started the cluster with cassandra 1.1.5.
> On the development system I didn't realize at first what was happening. I just wondered
that nodetool
> showed a very low amount of data. On integration I saw the problem quickly, but could
not recover the
> data. I re-installed the cassandra cluster from scratch, and populated it with our test
data, so our
> developers could work.
>  ...  
>   TIA, Thomas

View raw message