You can use something like the maven shade plugin to use both of the libthrift jars.

On Thu, Aug 9, 2012 at 3:57 PM, Jose Flexa <jose.flexa@gmail.com> wrote:
Hi.
I´ve avoided the issue by disabling assertions (-da).  Any suggestions
on a better strategy?

Thanks
José

On Thu, Aug 9, 2012 at 5:29 PM, Jose Flexa <jose.flexa@gmail.com> wrote:
> Hi,
>
> I am triggering the assertion at the start of
> ColumnFamilyStore.getRangeSlice when setting a SlicePredicate with
> sliceRange.setStart(new byte[0]), sliceRange.setFinish(new byte[0]);
> sliceRange.setCount(Integer.MAX_VALUE); in a AWS EMR job flow. AWS EMR
> uses libthrift 0.7.0 but my cassandra cluster uses libthrift 0.6.0
> (cassandra 1.0.8).
>
> Thanks
> José



--
Tyler Hobbs
DataStax