cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aaron morton <aa...@thelastpickle.com>
Subject Re: Increased replication factor not evident in CLI
Date Thu, 12 Jul 2012 22:44:09 GMT
Do multiple nodes say the RF is 2 ? Can you show the output from the CLI ? Do show schema and
show keyspace say the same thing ?

Cheers



-----------------
Aaron Morton
Freelance Developer
@aaronmorton
http://www.thelastpickle.com

On 13/07/2012, at 7:39 AM, Dustin Wenz wrote:

> We recently increased the replication factor of a keyspace in our cassandra 1.1.1 cluster
from 2 to 4. This was done by setting the replication factor to 4 in cassandra-cli, and then
running a repair on each node.
> 
> Everything seems to have worked; the commands completed successfully and disk usage increased
significantly. However, if I perform a describe on the keyspace, it still shows replication_factor:2.
So, it appears that the replication factor might be 4, but it reports as 2. I'm not entirely
sure how to confirm one or the other.
> 
> Since then, I've stopped and restarted the cluster, and even ran an upgradesstables on
each node. The replication factor still doesn't report as I would expect. Am I missing something
here?
> 
> 	- .Dustin
> 


Mime
View raw message