cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prakrati Agrawal <>
Subject Effective ownership on both nodes 0 %
Date Mon, 11 Jun 2012 06:20:09 GMT
Dear all

I have a Cassandra cluster with 2 nodes.
I was trying to increase the replication factor of keyspace in Cassandra to 2. I did the following
UPDATE KEYSPACE demo WITH strategy_options = {DC1:2,DC2:2}; on both the nodes
Then I ran the nodetool repair on both the nodes
Then I ran my Hector code to count the number of rows and columns in the database.
I get the following error: Unavailable Exception
Also when I run the command
./nodetool -h ip_address ring
I found that both nodes ownership is 0 %. Please tell me how should I fix that.

Thanks and Regards

This email message may contain proprietary, private and confidential information. The information
transmitted is intended only for the person(s) or entities to which it is addressed. Any review,
retransmission, dissemination or other use of, or taking of any action in reliance upon, this
information by persons or entities other than the intended recipient is prohibited and may
be illegal. If you received this in error, please contact the sender and delete the message
from your system.

Mu Sigma takes all reasonable steps to ensure that its electronic communications are free
from viruses. However, given Internet accessibility, the Company cannot accept liability for
any virus introduced by this e-mail or any attachment and you are advised to use up-to-date
virus checking software.

View raw message