cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From koji Lin <koji....@gmail.com>
Subject Re: Using EC2 ephemeral 4disk raid0 cause high iowait trouble
Date Wed, 23 May 2012 01:09:19 GMT
Hi
I think amazon ami is based on RHEL.

thank you

2012/5/21 aaron morton <aaron@thelastpickle.com>

> Are you using the Ubuntu operating system ?
>
> Cheers
>
>   -----------------
> Aaron Morton
> Freelance Developer
> @aaronmorton
> http://www.thelastpickle.com
>
> On 18/05/2012, at 1:59 PM, koji Lin wrote:
>
> Hi
>
> We use amazon ami 3.2.12-3.2.4.amzn1.x86_64
>
> and some of our data file are more than 10G
>
> thanks
>
> koji
> 2012-5-16 下午6:00 於 "aaron morton" <aaron@thelastpickle.com> 寫道:
>
>> On Ubuntu ? Sounds like http://wiki.apache.org/cassandra/FAQ#ubuntu_hangs
>>
>> Cheers
>>
>>
>>   -----------------
>> Aaron Morton
>> Freelance Developer
>> @aaronmorton
>> http://www.thelastpickle.com
>>
>> On 16/05/2012, at 2:13 PM, koji Lin wrote:
>>
>> Hi
>>
>> Our service already run cassandra 1.0 on 1x ec2 instances(with ebs), and
>> we saw lots of discussion talk about using  ephemeral raid for better
>> performance and consistent performance.
>>
>> So we want to create new instance using 4 ephemeral raid0, and copy the
>> data from ebs to finally replace the old instance and reduce some .
>>
>> we create the xlarge instance with -b '/dev/sdb=ephemeral0' -b
>> '/dev/sdc=ephemeral1' -b '/dev/sdd=ephemeral2' -b '/dev/sde=ephemeral3',
>>
>> and use mdadm command like this  mdadm --create /dev/md0 --level=0 -c256
>> --raid-devices=4 /dev/sdb /dev/sdc /dev/sdd /dev/sde
>>
>> after copying file and start the cassandra(same token as old instance it
>> replaced).
>>
>> we saw the read is really fast always keep 2xxm/sec, but system load
>> exceed 40, with high iowait, and lots of client get timeout result. We
>> guess maybe it's the problem of ec2 instance, so we create another one with
>> same setting to replace other machine ,but the result is same . Then we
>> rollback to ebs with single disk ,read speed keeps at 1xmb/sec but system
>> becomes well .(using ebs with 2 disks raid0 will keep at 2xmb/sec and
>> higher iowait then single disk ,but still works)
>>
>> Is there anyone meet the same problem too ? or do we forget something to
>> configure?
>>
>> thank you
>>
>> koji
>>
>>
>>
>


-- 
Koji Lin
blog: http://www.javaworld.com.tw/roller/koji/

Mime
View raw message